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Editing MS12001 Template Files

How to use ComponentOne Studio VSView Reporting Edition:

Go to ‘Start’ -> ‘All Programs’ -> ComponentOne Studio -> VSVIEW 8.0 -
> Reporting Edition -> Report Designer

This will open up the window below, double-click vsrpt8.exe

, «¢ Windows7_0S (C:) » Program Files » ComponentOne Studio » VSVIEW 8.0 » Reporting Edition » bin

-

Organize ¥ Include in library ¥ Share with « Burn New folder

45X Favorites Name Date modified Type Size
Bl Desktop @1 vsrpt8.exe 2/26/2003 3:15 PM Application 486 KB

4. Downloads

n 3
=1 Recent Places
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Editing MS12001 Template Files

Open Windows Explorer and press ‘Alt’ to show the menu bar
Click ‘Tools->'Folder Options->View’
Check the button beside ‘Show hidden files..” (this only needs
to be done once). Then Click ‘ok’.

In VSReport click ‘Open’ and browse to the following location:
C:\ProgramData\/GR\MS12001\Templates
Scroll until you find Report.xm/ and click Open.

| Folder Options | 22 |

' L]
General | View [ Search @ Cpen i |£|
Folder views .
i the vi h as Details or | that 2z 3 .
You an s v fuch o Detls o or) Look in: [}, Tempiates ~| « ®m ek Ey
[ ApplytoFolders | [ Reset Folders Narne - Date modified i
Advanced settings: |Z| Opterna.xml 11/11/201512:41 ...
Files and Folders - < .
[E] Aways shaw icons, neverthumbnals e |2 opternalbltrpt.mnl 11/11/201512:54 ..,
gji“:al‘ﬁ :_'l“"_"" menus _ | |Z Report Extended.xml 4/13/201212:27 PM |?
play file icon on thumbnails = e
Display file size information in folder tips ‘;" REPU‘I’t.:{ml 4ﬂ3f2ﬂ12 12:2? FI M
[ Display the full path in the title bar (Classic theme only) L =
Hiddgo lasandisidens : |Z| Report_ACI_091905-EM.xml 10/12/201512:00 ... =
() Don't show hidden files, folders, or drives
@ Show hidden files, folders, and drives 4 | T | 3
[T Mgt dives in the Computecia
[ Hide extensions for known fils types ;
Hide protected operating system files (Recommended) = F“E name: IHEFIDI't Jl:ITII ODE-‘H
Files of type: IHEpDrt Definition Files (*=ml) LI Cancel |,-"‘

oK [ Caneel ][ pply : = ‘d. J GR
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Eile V&dit Format  View Help

Double click ‘Tabular Report Standard’ and then click on the
‘Design’ icon to start editing that template.

ﬂnmxu{.m ...... |§|f@3

R

:l,

@;m,hwm [ 2

E| Gru:uuped by Custorner

&l Grouped by Part number
& Grouped I::l},rTest
E Groyped b
=l Tabular report Bidirectional
& Tabular report Standard

bular report UnidirectionglB
& Tabular report Unidirectional RL...

Printg
Date
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Editing MS12001 Template Files

| Ele Edit Fomat View Help

This brings up the design window.

D@ sdex (bR o 21 ka0 2r 4R

\o|Ee

|RE|&ElasEs [%|ps9|Tan

od G

B Grouped by Customer

B Grouped by Part number

B Grouped by Test

B Grouped by Workstation

B Tabular report Bidirectional

B Tabular report Standard

B Tabular report Unidirectional RL...
B Tabular report Unidirectional RL...
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= Header

Printed on: Notw()

@/ Group 4 Footer

I s ; Part-nu#nRb sv...' b stétus- oo BB
<‘f‘ Page Header. . . . . .
m [Measurement Date]
7/ Graup 0 Header T Part ]+ —
@/ Group 2 Header [Fis Serial Mumber] & [Incremental Serial Mumber]
@/ Group 1 Header [ awelength]
@/ Group 4 Header [Fibiet Mumber]
= Deta
|—| [Measurament Daf] TeHA(UY | Part Nombar]) TI#([Fiua Serial Number] =", [Inerementa [Glbbal Test Staty [Wavelen [Fiber ) Iiffisndll Mf(isnul] if(ismd] Lrsnol SRt TG

[Fiber Mumber]

0/ Group 1 Footer

[ auelength]

@/ Group 2 kooter

[Fi Sierial Mumber] & [Incremental Serial Mumber]

@/ Group 0 Footer

[OUT Part Mumber]

@/ Group 3 Footer

[Meazurement Dlake]

@ Page Footer

@ Footer
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Ficture
PictureAlign
RTF
RunningSum
Subrepart
Tag

Text

Top

Visible
Width
WordWrap

Property | Value
(Mame) Label®
Align & - vsrLeftMiddle
Anchor 0-vsrATop
BackColor [ CecDOFFFF
Back Style 0 - vsrTransparent
Bord
wEorderStyle 0 - vsrBS Transpragent
<. Calculated True
F
CanShrink False
CheckBox 0 - verioChechkBox
Font Times Mew Roman
ForcePageBreak 0 - vsrMNone
ForeColor I 00000000
Format
Height 270
Hide Duplicates False
Left 180
LineSlant 0 - wsrLSMaline
LineSpacing 0
LineWidth 0
Link Target
Margin Bottom 0
Margin Left 0
Margin Right 0
Margin Top 0

0-vsrPALeft Top
False
0 - vsrMNoRunning Sum

[Measurement Date]
0

True

1580

False
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elal
| [Measurement Date] Trim([DUT Part Number])
/£ Group 4 Footer [Fiber Mur
n

Groun 1 Enntear

[l avelann

Note that there are ‘Headers’ and ‘Details’:
Headers have the ‘Calculated’ property ‘False’
and Details have the ‘Calculated’ property ‘True’.
Headers will be displayed on the report as they
are written in the designer.

Details will pull specific data from the database
and display that on the final report instead.

To edit a detail, double click on it to bring up the
‘Field Properties’ (shown left).
A non-exhaustive list of possible ‘details’ is
shown on the next slide.
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Editing MS12001 Template Files

Possible Data Fields:

* [Fixed Serial Number]

* [Incremental Serial Number]

» [Wavelength 1]

» [Wavelength 2]

* [Measurement Date]

* [Fiber Number]

* [IL Wavelength 1]

* [IL Wavelength 2]

* [IL EndA Wavelength 1]

* [IL EndA Wavelength 2]

* [IL EndB Wavelength 1]

* [IL EndB Wavelength 2]

* [IL Status]

* [IL]

* [IL EndA]

* [IL EndA Status]

* [Reflectance Wavelength 1]

* [Reflectance Wavelength 2]

* [Reflectance EndA Wavelength 1]
* [Reflectance EndA Wavelength 2]
* [Reflectance EndB Wavelength 1]
* [Reflectance EndB Wavelength 2]
» [Reflectance Status]

* [Reflectance]

* [Reflectance EndA Status]
* [Reflectance EndB Status]
* [Custom Field 1]

* [Custom Field 2]

* [Custom Field 3]

* [Custom Title 1]

* [Custom Title 2]

* [Custom Title 3]

* [Customer Name]

* [Operator Name]

» [Test Name]

* [Test Type]

* [Test Reflectance]

» [Test IL]

* [DUT Description]

* [DUT Length]

« [DUT Part Number]
* [DUT Manufacturer]
* [DUT Mode]

 [DUT Device Type]
* [DUT Mandrel-Free]
» [Workstation 1D]

* [Global Test Status

* [EndA Connector Name]

* [EndA IL Pass Limit]

* [EndA IL Warning Limit]

* [EndA Reflectance Pass Limit]
* [EndA Reflectance Warning
Limit]

* [EndB Connector Name]

* [EndB IL Pass Limit]

* [EndB IL Warning Limit]

* [EndB Reflectance Pass Limit]
* [EndB Reflectance Warning
Limit]
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The Text fields work with simple Visual Basic (VB6) commands. For example,
to set up the detail ‘Serial Number’, double click on the appropriate text field to

bring up the ‘Field PropertiesQ)ox.
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Field Properties . — \ =]
Property [ Value N |
(Mame) fdCombined Seral Mumber Teslt report
Align 6 - vsrLeftMiddle - Tabular detailled -
Anchor 0-vsrATop :
BackColor [T Cec DAOFFFFT E
Back Style 0 - verTransparent krmﬂumberostatus
BorderCaolor I 00000000 0 ' ' ’
BorderStyle 0 - werBSTransparent  Date]
Calculated True
CanGrow False el
CanShrink Falze ImidNgr] & [Inzremental Serial Mumber]
CheckBax 0 - wsrNoCheckBox N\
Fort Times New Roman ] )7
Force PageBreak 0 - wsrMNone —
E::;flm I (00000000 ~ Qar6([Fixed Serial Number] = ", [Incrementm[Glébal Tast Sta
Height 270 ]
Hide Duplicates Falze
Left 5325 (fmber] & [Incremental Serial RMumber]
Line Slant 0 - wsrLSMoLine || -
LineSpacing 0
LineWidth 0 |
Link Target
Margin Bottom 0
Margin Left 0
Margin Right 0
Margin Top 0
Picture
Picture Align 0-vsrPALeft Top
RTF False
RunningSum 0 - wsrMoRunning Sum
Subreport
Tag
Text MNumber] & "-" & [Incremental Seral Mumber])
Top
Visible True
Width 305
WordWrap Falze
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Field Properties -
Property |Va|ue

(Mame) fidCombined SeralMumber
Align & - varLeftMiddle
Anchor 0-vsrATop
BackColor [ DDOFFF

Back Style 0 - vsrTransparent
BorderColor Il 000000000
BorderStyle 0 - varBS Transparent
Calculated True

CanGrow False

CanShrink False

ChechkBaox 0 - wvarNoCheck Box
Faont Times Mew Roman
ForcePageBreak 0 - wsrNone
FareCaolor Il (00000000
Format

Height 270

HideDuplicates False

Left 5325

LineSlant 0 - verLSNoLine
LineSpacing 0

LineWidth 1]

Link Tanget

Margin Bottom 0

MarginLeft 0

Margin Right 0

Margin Top 0

Ficture

PictureAlign 0 -verPALeft Top
RTF Falge

Running Sum 0 - verMNoRunningSum
Subreport

Tag

Tead If{[Fixed Seral Mumber] =", [Incremertal Seral Mumber], [Fixed Seria...
Top 1]

Vizible True

Width 3015

WordWrap False
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Now we can edit the ‘Text’ using Visual
Basic to do some logic and formatting.

The current text field contains the
command:

lIf([Fixed Serial Number] = ", [Incremental
Serial Number], [Fixed Serial Number| & "-"

& [Incremental Serial Number])

Here we are saying /f the database field
[Fixed Serial Number] is nothing (*”) then
just use the database field [Incremental
Serial Number]. Otherwise use the Fixed

and Incremental Serial Numbers (&).
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Editing MS12001 Template Files

Let’'s assume we want to add a field for ‘Operator Name’.

To do this we must first make some space on the report. Drag a box around
everything past the ‘Part Number’ field to select it.

Now click and drag the selection to the right so it looks like the picture below.
We now have some space between ‘Part number’ and ‘Serial Number’.

Tést repnft

- Tabular detailled -

E_be i:l EIEIEIEIE]EIDEI_EIIIEIIIIEID:I,EIIIIEIIIIEEID:IEID
--------- FAR- TR o B Gy T B CICHEE - LT LERE e LTk o LR @Rl LR B CTREARB -1
: r tm ! [ M ] L o IR RO m

nh—r-rr—rr+—r——rr—r-—rri n—rri—r

Diate]
1ber]

ber] & [Incremental Serial humber]

> . o = I o L = O o O . O o T (e = w1
CY([Fixe Seial Nosnfer] ="' ocsemen§(L0Gobal Tes Sat (LWl iber TSt 8l T o A sl ATl e T4 i
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Editing MS12001 Template Files

Insert a new Label in the blank space by selecting the ‘Label
command in the toolbar and then drawing the label to the
appropriate size. \

? [W\ag 2P 2@\ o BE

R e BT

r 1 - - - - z - - - T ' 5 - - - a1 - - - E - - -
= Header

Tést repoﬁ

-~ Tabular detailled -

Printed on: Now()

e Date pmﬂumher¢ ........................... E;abe.ﬁ;j ........... : ........................... E g,eﬂal mberc- .......................
= Page Header
=/ fraup 3 Header [Measurement Date]
=/ Group 0 Header [DUT Part Mumber]
=/ fGroup 2 Header [Fi Serial Mumber] & [Incremental Serial Mumber]
=/ Group 1 Header [ awelength]
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Editing MS12001 Template Files

.

egropeics DL
Property | Value |
(Mame) Labell
Align -1 - varGeneral
Anchor 0 -wvsrATop
BackCalaor [ D OOFFFH
BackStyle 0 - vsrTransparent
BorderColor I 00000000
BorderStyle 0 - vsrBS Transparent
Calculated Falzse
CanGrow False
CanShrink False
CheckBox 0 - warNaCheck Box
Fort Arial
ForcePageBreak 0 - verione
ForeColar I (00000000
Format
Height 270
Hide[Duplicates Falze
Left 5310
LineSlant 0 - wsrLSMNoLine
LineSpacing 1]

LineWidth 1]

Link Target

MarginBattom 0

MarginLeft 0

MarginRight 0

Margin Top 0

Ficture

FictureAlign 0 - verPALeft Top
RTF Falzse
RunningSum 0 - wsrNoRunningSum
Subreport

Tag

Text Cperator Name
Top 1305

Wisible True

Width 1800

WaordWrap True
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Double-click on the new label and
edit the ‘Text’ field to say ‘Operator

Name’.

Note that the ‘Calculated’ field is set

to false since this is just a label.
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| Field Properties : : :
— —Mm ] Test report

(Name) fdCperator - Tabular detailled - ‘

Align -1 - varGeneral 1 H J
Anchor 0 -wsrATop NOW go to the Detalls
BackColar [ DS -ppax-xto' Mame I Serial number H‘Statns ....................

Wl : section and insert
rderStyle 0 - vsrBSTral rert ate]

Calculated True ; petl another |abe| as

(Grow False ber] & [Incremental Serial Momber]

g;akBox 0 - vsrNoCheck Box ] ShOWn .

Fant Aial

E:::::,greareak : % [SOperator Name] ) iLf([Fixed Serial Numper] = ", [Tncrementa [Global Test Stat

Format 1 . .

2 Bring up the properties
HideDuplicates False ber] & [Incremental Serial Mumber]

tizsmm 33-1\:]5rLSNoLine e W| n d ow by d ou b I e-

a0 clicking and change
UnkTargei 1 ) H
ogntet 0 the ‘Text’ field to
Margin Right 0
0 [Operator Name] and
O the ‘Calculated’ field to
SE:ningSum 1 - wsrNoRunningSum ‘T ru e,

|| T:fd [Dperator Name]
N r— 0 :
Visible - Tue
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We have now successfully added a new field to the report. Unfortunately this also
pushes the last field off the page. (The page is as wide as the Test report’ bar)

To rectify this simply shrink the size of the ‘Part number’ and ‘Serial Number’ fields.
Then move the fields so they are all adjacent as shown below.

— I FEEEE R TR D R TR D TR [ PEEEFEE T
= Header
Test report
- Tabular detailled-
' Page Header . . . ' . ' . '
'/ Group 3 Header [Measurement Date]
0/ Group 0 Header [DUT Part Mumber]
'/ [roup 2 Header [Fix Serial Mumber] & [Incremental Serial Mumber]
'/ Group 1 Header ['W avelength]
'/ Group 4 Header [Fiber Mumber]
= Detail
|_|swemeut Dats] Teim([DUT Part Number]) | [OperatorName] | Ie([Fixed Serial Nomber] = !", [In [Global Tst Staty [Wavelen [Fiber? If(isnull Mfisnall Df(isnull If(anull TfGenul] Mfisnol
7 Group 4 Footer [Fiber Kumber]
0/ Group 1 Footer [ avelength]

'/ Group 2 Footer

[Fit Serial Mumber] & [Incremental Serial Mumber]

0/ (Group 0 Footer

[OUT Part Mumiber]

'/ Group 3 Footer

[IMeasurement Date]

" Page Footer

" Footer
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Finally, save the new report into the same folder as the original
template.

(File-> Save As)

)

Save in:I . Templates j = EF Ed~

Marme Date modified

2| Chart Extended.xml 2/3/2012 7:29 AM
& Chartxml 2/3/2012 7:29 AM
|Z| Label Extended.xml 2/3/2012 7:29 AM
2| Labelxml 2/3/2012 7:29 AM

% Report BExtended.xml 2/3/2012 7:29 AM
4 | 10

File name: |newHepurt xml

Save as type: IHepnrt Definition Files (*ml) ;I

The new report template is now available to select in the MS12001
software.
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